summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-05 15:08:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-05 15:08:57 +0300
commitb358baf3a1088f619196d925166cb5272184c5d7 (patch)
treefb3f4c5a392f2a7d056cd25f6556ee75354b86f8 /x11-misc
parentnet-misc/nx: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-b358baf3a1088f619196d925166cb5272184c5d7.tar.gz
gentoo-b358baf3a1088f619196d925166cb5272184c5d7.tar.bz2
gentoo-b358baf3a1088f619196d925166cb5272184c5d7.zip
x11-misc/menulibre: add 2.4.0
Closes: https://bugs.gentoo.org/905423 Closes: https://bugs.gentoo.org/929886 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/menulibre/Manifest1
-rw-r--r--x11-misc/menulibre/menulibre-2.4.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/menulibre/Manifest b/x11-misc/menulibre/Manifest
index 7cefa9c09d5d..b7551ede605b 100644
--- a/x11-misc/menulibre/Manifest
+++ b/x11-misc/menulibre/Manifest
@@ -1 +1,2 @@
DIST menulibre-2.2.3.tar.gz 488117 BLAKE2B 2bb157f6f8fb1af8c5059bfa2f93dbf99eb3a0cf9b3072cae28284d50c6a7d847da7a7dc5905ff59386f7d69029f7ffd7c39cb9137e029355fea2f52741283c6 SHA512 bd554606ad35cdd41272ed656427ae3f610d6aacfc9e91e4de6ed342034e1bb6070812017a1372d04b0df4008ae1cd7207ca243142a874b6abb0a00893740da3
+DIST menulibre-2.4.0.tar.gz 520920 BLAKE2B c55dbb077db2af477dc9c1882449981ff15cb66b9c12ea4433ed11a1649f9dedfa8c743ca15f54b5cfd9993c8d8ae3398fd0c87c4b5e3199f5e291029f9c81af SHA512 0c520d9cab6d9eccaa9119c4ff771dbef913909202b3f2d600f4b71f5b2db87c71df35c6d8374099fda07b33b6c02686bd6b53ca0fa3d4dbd439b3c5cdcb2839
diff --git a/x11-misc/menulibre/menulibre-2.4.0.ebuild b/x11-misc/menulibre/menulibre-2.4.0.ebuild
new file mode 100644
index 000000000000..b3658ab5b65b
--- /dev/null
+++ b/x11-misc/menulibre/menulibre-2.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+inherit distutils-r1 xdg
+
+DESCRIPTION="Advanced freedesktop.org compliant menu editor"
+HOMEPAGE="https://bluesabre.org/projects/menulibre"
+SRC_URI="https://github.com/bluesabre/menulibre/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gnome-base/gnome-menus:3[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-themes/hicolor-icon-theme
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ ')
+ dev-util/intltool
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # show desktop entry in all DEs
+ sed -i '/^OnlyShowIn/d' menulibre.desktop.in || die
+
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+}