summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-20 21:25:34 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-26 23:53:05 +0200
commitded91d6bc1f2f82fe10deb8558960e381c5e3769 (patch)
tree7d918a0b12fbb80a22ca989194c8a018d622fb36 /x11-plugins
parentx11-misc/mixer_app: EAPI7, improve ebuild (diff)
downloadgentoo-ded91d6bc1f2f82fe10deb8558960e381c5e3769.tar.gz
gentoo-ded91d6bc1f2f82fe10deb8558960e381c5e3769.tar.bz2
gentoo-ded91d6bc1f2f82fe10deb8558960e381c5e3769.zip
x11-plugins/bfm: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/bfm/bfm-0.6.4-r3.ebuild40
-rw-r--r--x11-plugins/bfm/files/bfm-0.6.4-makefile.patch4
2 files changed, 42 insertions, 2 deletions
diff --git a/x11-plugins/bfm/bfm-0.6.4-r3.ebuild b/x11-plugins/bfm/bfm-0.6.4-r3.ebuild
new file mode 100644
index 000000000000..825865105964
--- /dev/null
+++ b/x11-plugins/bfm/bfm-0.6.4-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime"
+HOMEPAGE="https://github.com/JNRowe-retired/bfm"
+SRC_URI="https://github.com/JNRowe-retired/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gkrellm"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gkrellm? ( >=app-admin/gkrellm-2 )"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
+ use gkrellm && emake gkrellm CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin bubblefishymon
+
+ doman doc/*.1
+ dodoc ChangeLog* README* doc/*.sample
+
+ if use gkrellm; then
+ insinto /usr/$(get_libdir)/gkrellm2/plugins
+ doins gkrellm-bfm.so
+ fi
+}
diff --git a/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch b/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch
index 773372e1020c..21c183c12079 100644
--- a/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch
+++ b/x11-plugins/bfm/files/bfm-0.6.4-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2015-01-20 10:56:34.791157688 +0100
-+++ Makefile 2015-01-20 10:56:48.135154215 +0100
+--- a/Makefile 2015-01-20 10:56:34.791157688 +0100
++++ b/Makefile 2015-01-20 10:56:48.135154215 +0100
@@ -26,21 +26,21 @@
EXTRA += $(WMAN)