summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-18 18:31:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-21 17:05:32 +0200
commitb631378bb4f68c193f08b3184051484081e05d04 (patch)
tree6cb9a080c75441ceaf8bab9b12340e118aeb74ea /x11-terms
parentx11-misc/rofi-calc: add 2.2.1 (diff)
downloadgentoo-b631378bb4f68c193f08b3184051484081e05d04.tar.gz
gentoo-b631378bb4f68c193f08b3184051484081e05d04.tar.bz2
gentoo-b631378bb4f68c193f08b3184051484081e05d04.zip
x11-terms/sakura: add 3.8.7
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37605 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/sakura/Manifest1
-rw-r--r--x11-terms/sakura/sakura-3.8.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/sakura/Manifest b/x11-terms/sakura/Manifest
index 6263e2f6df9c..fb3cfa4d5148 100644
--- a/x11-terms/sakura/Manifest
+++ b/x11-terms/sakura/Manifest
@@ -1 +1,2 @@
DIST sakura-3.8.4.tar.bz2 70492 BLAKE2B 4f53a86813de49d1f76c0a209a825b19601a22b4078744a0e4dfe21afd000e524a3705e8125b275b3615b35e5e7f38934270baa73d190e06dabf4284d4dab536 SHA512 9450f523555a40c66375304cb4134686dddd1b15233a70e488d1220fbdacd46b8e93cb679bbd1c235cc8d08f08551743b4780130d282d94d258247436a84ed61
+DIST sakura-3.8.7.tar.bz2 60003 BLAKE2B 56d0b57dbd5db57662ce9a286bbfde709d86ce41cf6dca3598d0ac095f9fee6e88051214a1092c65126e238719914b4209fbc485b2f97ceda96e4f3f9bb10d58 SHA512 ec606af0ab808e93366a08ef36199ef7e23677e7aac4765573604230c9ea498a14d6f22983ab7285030e6d10f432b7ad924f33660bce8bc05bd76a2c31c1a76b
diff --git a/x11-terms/sakura/sakura-3.8.7.ebuild b/x11-terms/sakura/sakura-3.8.7.ebuild
new file mode 100644
index 000000000000..4cee2fd88724
--- /dev/null
+++ b/x11-terms/sakura/sakura-3.8.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="GTK/VTE based terminal emulator"
+HOMEPAGE="https://www.pleyades.net/david/projects/sakura"
+SRC_URI="https://launchpad.net/sakura/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~x86-linux"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3[X]
+ x11-libs/pango
+ x11-libs/vte:2.91"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11"
+BDEPEND="
+ sys-devel/gettext
+ virtual/perl-podlators"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.8.4-gentoo.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if [[ -v LINGUAS ]]; then
+ local lingua
+ for lingua in po/*.po; do
+ lingua=${lingua#*/}
+ lingua=${lingua%.*}
+ has ${lingua} ${LINGUAS} || rm po/${lingua}.po || die
+ done
+ fi
+}