summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-10-02 10:00:33 +0200
committerPacho Ramos <pacho@gentoo.org>2022-10-02 10:00:33 +0200
commit91bafb832189e185d36c3d512f6781ff3a969414 (patch)
tree633be07e1a618914f0d6b2a11d0c28cce189ae00 /x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild
parentx11-themes/adwaita-qt: drop 1.3.1, 1.4.0 (diff)
downloadgentoo-91bafb832189e185d36c3d512f6781ff3a969414.tar.gz
gentoo-91bafb832189e185d36c3d512f6781ff3a969414.tar.bz2
gentoo-91bafb832189e185d36c3d512f6781ff3a969414.zip
x11-themes/QGnomePlatform: add 0.9.0
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild
new file mode 100644
index 000000000000..935a1bad9776
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtdbus:5=
+ >=dev-qt/qtwidgets-5.15.2:5=
+ dev-qt/qtwayland:5=
+ dev-qt/qtx11extras:5=
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/xdg-desktop-portal
+ x11-libs/gtk+:3[X]
+ >=x11-themes/adwaita-qt-1.4.2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT6=false
+ )
+ cmake_src_configure
+}