summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gtk-engines-unico
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gtk-engines-unico')
-rw-r--r--x11-themes/gtk-engines-unico/Manifest2
-rw-r--r--x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20121212.ebuild41
-rw-r--r--x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109.ebuild40
-rw-r--r--x11-themes/gtk-engines-unico/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-unico/Manifest b/x11-themes/gtk-engines-unico/Manifest
new file mode 100644
index 000000000000..fda9b6a71d65
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/Manifest
@@ -0,0 +1,2 @@
+DIST unico-1.0.3_pre20121212.tar.bz2 276446 SHA256 0fc028dc01cded59d983608397316297a1be6cabf747b606caa55da62656993e SHA512 654a3ce9532a1f9537b45f0549b9cdd956232e6b0d933460ea58f85065fa6b82d1d82856b71c09a9227a47b237ebcc0c8f6759c34ff685c238dbe104529c1954 WHIRLPOOL f4f233f75221e50552ffd79e72e44d31c1ccf063acd8835fbeb4508dedf3978acb6323f42f953928bc5afe11ee6bb1b2e8620977b9029fb6438d497c3fccaa90
+DIST unico_1.0.3+14.04.20140109.orig.tar.gz 19416 SHA256 6f96674e17126ce6daadf186604bd2f46d68073fa8b1ade3ddf70384df085df7 SHA512 8112240d63ffca2cbbaecc6731ef446153d8dd8b2b100c2d258013faa20b683761ba4768e71e91bdc885d1174874341e68400d1d3ebf95dc92db47cca7221de5 WHIRLPOOL 33aaec39d14ce79fafeaed1cab5169293c2f482ee7c5939f2d7ee45387c36da04b56ad3c297c80c9d386a6f7ca2d7d8323cc9b491467b30ab5c42df5962ccfe0
diff --git a/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20121212.ebuild b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20121212.ebuild
new file mode 100644
index 000000000000..bf8178981b38
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20121212.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+MY_PN=${PN/gtk-engines-}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The Unico GTK+ 3.x theming engine"
+HOMEPAGE="https://launchpad.net/unico"
+#SRC_URI="https://launchpad.net/${MY_PN}/${PV%.*}/${PV}/+download/${MY_P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/cairo-1.10[glib]
+ >=x11-libs/gtk+-3.5.2:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-1.0.2
+
+src_configure() {
+ # $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
+ # unused in the code itself.
+ econf \
+ --disable-static \
+ --disable-debug \
+ --disable-maintainer-flags
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
diff --git a/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109.ebuild b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109.ebuild
new file mode 100644
index 000000000000..2ba3f9013157
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/gtk-engines-unico-1.0.3_pre20140109.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
+
+inherit autotools-multilib eutils
+
+MY_PN=${PN/gtk-engines-}
+MY_PV=${PV/_pre/+14.04.}
+MY_P=${MY_PN}_${MY_PV}
+
+DESCRIPTION="The Unico GTK+ 3.x theming engine"
+HOMEPAGE="https://launchpad.net/unico"
+SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${MY_P}.orig.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.10[glib,${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.5.2:3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${MY_PV}
+
+src_configure() {
+ # $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
+ # unused in the code itself.
+ autotools-multilib_src_configure \
+ --disable-static \
+ --disable-debug \
+ --disable-maintainer-flags
+}
diff --git a/x11-themes/gtk-engines-unico/metadata.xml b/x11-themes/gtk-engines-unico/metadata.xml
new file mode 100644
index 000000000000..9fd4d4fbe5c5
--- /dev/null
+++ b/x11-themes/gtk-engines-unico/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="launchpad">ubuntu</remote-id>
+ </upstream>
+</pkgmetadata>