summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-21 15:54:03 -0500
committerDavid Seifert <soap@gentoo.org>2018-04-22 15:00:46 +0200
commit67873482e7d29fb310f43ab793ce8b5e53b177b0 (patch)
tree5ae872acd5cb5f26606216a0205d9b2ccf6bab09 /x11-themes/wm-icons/wm-icons-0.4.0.ebuild
parentx11-themes/pulse-glass: EAPI bump (diff)
downloadgentoo-67873482e7d29fb310f43ab793ce8b5e53b177b0.tar.gz
gentoo-67873482e7d29fb310f43ab793ce8b5e53b177b0.tar.bz2
gentoo-67873482e7d29fb310f43ab793ce8b5e53b177b0.zip
x11-themes/wm-icons: EAPI bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'x11-themes/wm-icons/wm-icons-0.4.0.ebuild')
-rw-r--r--x11-themes/wm-icons/wm-icons-0.4.0.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
index 0ab33021870c..ce4217eaf635 100644
--- a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
+++ b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
@@ -1,31 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-DESCRIPTION="A Large Assortment of Beutiful Themed Icons, Created with FVWM in mind"
+EAPI=6
+DESCRIPTION="A Large Assortment of Beautiful Themed Icons, Created with FVWM in mind"
HOMEPAGE="http://wm-icons.sourceforge.net/"
SRC_URI="mirror://sourceforge/wm-icons/wm-icons-${PV}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-
IUSE=""
+
RDEPEND="virtual/awk dev-lang/perl"
DEPEND="${RDEPEND} sys-devel/autoconf sys-devel/automake sys-apps/sed"
-src_compile() {
- econf --enable-all-sets --enable-icondir=/usr/share/icons/wm-icons || die "econf failed"
- emake || die
+src_configure() {
+ econf --enable-all-sets \
+ --enable-icondir="${EPREFIX}"/usr/share/icons/wm-icons
}
src_install() {
- make icondir="${D}/usr/share/icons/wm-icons" DESTDIR="${D}" install
+ # strange makefile...
+ emake icondir="${ED%/}/usr/share/icons/wm-icons" DESTDIR="${D}" install
einfo "Setting default aliases..."
- "${D}"/usr/bin/wm-icons-config --force --user-dir="${D}/usr/share/icons/wm-icons" --defaults
+ "${ED%/}/usr/bin/wm-icons-config" --force --user-dir="${ED%/}/usr/share/icons/wm-icons" --defaults
- dodoc AUTHORS ChangeLog NEWS README
+ einstalldocs
}
pkg_postinst() {