summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/enlightenment/enlightenment-1.0.11.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/enlightenment/enlightenment-1.0.11.ebuild')
-rw-r--r--x11-wm/enlightenment/enlightenment-1.0.11.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/enlightenment-1.0.11.ebuild b/x11-wm/enlightenment/enlightenment-1.0.11.ebuild
new file mode 100644
index 000000000000..1c44720d0971
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-1.0.11.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+if [[ ${PV} == *9999 ]] ; then
+ ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/E16/e"
+ inherit subversion autotools
+ SRC_URI=""
+ #KEYWORDS=""
+ S=${WORKDIR}/e16/e
+else
+ SRC_URI="mirror://sourceforge/enlightenment/e16-${PV/_/-}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+ S=${WORKDIR}/e16-${PV/_pre?}
+fi
+inherit eutils
+
+DESCRIPTION="Enlightenment Window Manager (e16)"
+HOMEPAGE="http://www.enlightenment.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="dbus doc nls pango pulseaudio xcomposite xinerama xrandr"
+
+RDEPEND="pulseaudio? ( media-sound/pulseaudio )
+ dbus? ( sys-apps/dbus )
+ pango? ( x11-libs/pango )
+ =media-libs/freetype-2*
+ >=media-libs/imlib2-1.3.0[X]
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ x11-libs/libXxf86vm
+ x11-libs/libXft
+ xrandr? ( x11-libs/libXrandr )
+ x11-libs/libXrender
+ x11-misc/xbitmaps
+ xinerama? ( x11-libs/libXinerama )
+ xcomposite? ( x11-libs/libXcomposite )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+ xcomposite? ( x11-proto/compositeproto )
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( app-doc/edox-data )"
+
+src_prepare() {
+ if [[ ! -e configure ]] ; then
+ eautopoint
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ $(use_enable pulseaudio sound-pulse) \
+ --disable-sound-esound \
+ $(use_enable pango) \
+ $(use_enable xinerama) \
+ $(use_enable xrandr) \
+ $(use_enable xcomposite composite) \
+ --disable-docs \
+ --enable-zoom
+}
+
+src_install() {
+ default
+ dodoc COMPLIANCE sample-scripts/*
+ dohtml docs/e16.html
+}