summaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2018-03-17 13:54:09 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-17 22:00:56 +0100
commit95e45024a65624372d261621a54c17d2a2eea242 (patch)
tree1d29ee1304e42a4a615b1cc3e9cd8332e9de6098 /x11-wm/i3
parentdev-vcs/tortoisehg: Bump to version 4.5.2 (diff)
downloadgentoo-95e45024a65624372d261621a54c17d2a2eea242.tar.gz
gentoo-95e45024a65624372d261621a54c17d2a2eea242.tar.bz2
gentoo-95e45024a65624372d261621a54c17d2a2eea242.zip
x11-wm/i3: Bump to 4.15
Closes: https://bugs.gentoo.org/650218 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7485
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/Manifest1
-rw-r--r--x11-wm/i3/i3-4.15.ebuild111
2 files changed, 112 insertions, 0 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 024f479e2632..918f8f2a0264 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -1,3 +1,4 @@
DIST i3-4.13.tar.bz2 1121298 BLAKE2B 94f3940406d43083c8dc577b4216a32a08ad4c4b58e7707cc9e3129038f4d13043c1f86e8de03d0fdfcff73f0de582fc8b3c88d71c0161ac3eefe28329f67a64 SHA512 1bb1044e8d86e78d3ccb79d49f0eb26665dcd05a348058a5e57138151d74f57d77830efc3025893170fe1b8ec612f739f75247a427410f96286b09afd2c5f14c
DIST i3-4.14.1.tar.bz2 1173560 BLAKE2B 96a0e1d75be13098fd530c3970464ce7710063f517c0d538939de6e7c799ab6b3ec005fb50216b1db4ccefd44584c584b263ac359bd9a86be53418d8f8d4beba SHA512 ef628af002947b40e1c88b0e872c6e93d4377a9674a120bd9adc3f323a38570b05124cd3047b5a26659e72070de2d00d83fb93186510c74ad8ddbf4f3df85472
DIST i3-4.14.tar.gz 3936748 BLAKE2B 42678130be56bc695e5700e978ddbd34bfdaeda7a65252a05568581d76fe613e80e710f3a507110e7988077fe62048bf984d4009e722d877b178206cef600221 SHA512 fe3db78813987a15ed93d182968bcd5139e1d03f29d3e8effd9fce59f87bc8309407af0b2fa5f1cd83b8583e50ea0ade6b8eafc5dda6dea9161832dc9cebfdfe
+DIST i3-4.15.tar.bz2 1196263 BLAKE2B 36f20327202957dba30aface91af4d2c6261979e726584712a508a11cb4a612d812e771dc9f28ec4cfcbf3ebc9d92c72f5e940048516cca0f185eab20f95ae32 SHA512 60ab61b7e380342126bea12fb4371f98fcf18f6435f79a9519d3f59cfabdb170634366036e1aa20c5592da0832b03140ad1f0c72bad3cfaace0b7c57ad01dfc4
diff --git a/x11-wm/i3/i3-4.15.ebuild b/x11-wm/i3/i3-4.15.ebuild
new file mode 100644
index 000000000000..3c204ad407fc
--- /dev/null
+++ b/x11-wm/i3/i3-4.15.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+AEVER=0.17
+
+inherit autotools out-of-source virtualx
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="https://i3wm.org/"
+SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug test"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+ >=x11-libs/cairo-1.14.4[X,xcb]
+ >=x11-libs/pango-1.30.0[X]"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ doc? ( app-text/xmlto dev-lang/perl )
+ test? (
+ dev-perl/AnyEvent
+ >=dev-perl/X11-XCB-0.120.0
+ dev-perl/Inline
+ dev-perl/Inline-C
+ dev-perl/IPC-Run
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/local-lib
+ >=virtual/perl-Test-Simple-0.940.0
+ x11-base/xorg-server[xephyr]
+ )
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+
+# Test without debug will apply optimization levels, which results
+# in type-punned pointers - which in turn causes test failures.
+REQUIRED_USE="test? ( debug )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-musl-GLOB_TILDE.patch"
+)
+
+# https://github.com/i3/i3/issues/3013
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ eautoreconf
+}
+
+my_src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+my_src_test() {
+ emake \
+ test.commands_parser \
+ test.config_parser \
+ test.inject_randr15
+
+ virtx perl \
+ -I "${S}/testcases/lib" \
+ -I "${BUILD_DIR}/testcases/lib" \
+ testcases/complete-run.pl
+}
+
+my_src_install_all() {
+ doman man/*.1
+
+ einstalldocs
+ use doc && dodoc -r docs "RELEASE-NOTES-${PV}"
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}/i3wm"
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}