summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-01 15:09:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-01 15:49:36 +0100
commit336a6e93c9f6456d33fddc1ff82ca6d5bd617bd8 (patch)
tree8ed466f21643597f22c4531ff3a5b467e72dc910 /xfce-base/xfce4-appfinder/xfce4-appfinder-4.19.4.ebuild
parentxfce-base/xfce4-appfinder: Remove old (diff)
downloadgentoo-336a6e93c9f6456d33fddc1ff82ca6d5bd617bd8.tar.gz
gentoo-336a6e93c9f6456d33fddc1ff82ca6d5bd617bd8.tar.bz2
gentoo-336a6e93c9f6456d33fddc1ff82ca6d5bd617bd8.zip
xfce-base/xfce4-appfinder: Bump to 4.19.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfce4-appfinder/xfce4-appfinder-4.19.4.ebuild')
-rw-r--r--xfce-base/xfce4-appfinder/xfce4-appfinder-4.19.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/xfce-base/xfce4-appfinder/xfce4-appfinder-4.19.4.ebuild b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.19.4.ebuild
new file mode 100644
index 000000000000..3dcd99179b91
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.19.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-appfinder/start
+ https://gitlab.xfce.org/xfce/xfce4-appfinder/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/garcon-4.18.0:=
+ >=xfce-base/libxfce4util-4.18.0:=
+ >=xfce-base/libxfce4ui-4.18.0:=[gtk3(+)]
+ >=xfce-base/xfconf-4.18.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}