summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-02 23:43:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-03 00:01:06 +0100
commit7a335004da12a9813eb9c842a90464421be11ece (patch)
treec52a1c68bf54b564539f269b97d79a5a1b436fc1 /xfce-extra/xfce4-cpufreq-plugin
parentapp-misc/anki: add github remote-id (diff)
downloadgentoo-7a335004da12a9813eb9c842a90464421be11ece.tar.gz
gentoo-7a335004da12a9813eb9c842a90464421be11ece.tar.bz2
gentoo-7a335004da12a9813eb9c842a90464421be11ece.zip
xfce-extra/xfce4-cpufreq-plugin: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-cpufreq-plugin')
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/Manifest b/xfce-extra/xfce4-cpufreq-plugin/Manifest
index f221f7022642..d9e918429a46 100644
--- a/xfce-extra/xfce4-cpufreq-plugin/Manifest
+++ b/xfce-extra/xfce4-cpufreq-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-cpufreq-plugin-1.2.2.tar.bz2 408480 BLAKE2B da6f38a57126b8ad06dd77c9a1f09ffee78e58b390b53b5020af8da403b51f20ed8965b9d0bd0da2add993228d19ec9fcaa15ea4c22b42011140a8bfdb440dfa SHA512 b0cab40fa0e6cdbb59606d7712b1b1479e4a1e8ca1aa5a59d43fc863ac10eee6477461c827805d7544db49fa6e821f0351973fe650e2ef1520ddcadcbbde096e
DIST xfce4-cpufreq-plugin-1.2.3.tar.bz2 415151 BLAKE2B 5c3c1298c5dc0562f4daf8df9c4f9e0d26b638f85efc5ec35d8edc08bb54a8de46b5af98c603fad6042eca0353419ae4f55cb642dcac7e3ef47509fbb712d58f SHA512 e8e9d705f304681253b6e8fb7ff8724dc7c339fda750c2fb7f05dc4f295b483679c0e2884e508c108ca9018499b50f4ff48a7d4dae5ef7c8ab78f0018f1ef959
+DIST xfce4-cpufreq-plugin-1.2.4.tar.bz2 416385 BLAKE2B 65df9bdd0427f5cdebe1a3427801b2ac69fa04a1b6da069c15a7463927101a6744e99207de69bd8ed6f0a92259fcaaa34a25e7cb26b74f82a9bfad38ddab8cda SHA512 6aad36cf44ebde55e9d05cabe8547e9335188749ce92317c949c00577b04a80f2239c03664802ef386a06a2c24c433a515dc598ea36c9299766a5e56b5ae6ae4
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.4.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.4.ebuild
new file mode 100644
index 000000000000..3bf59fb4081e
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}