summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-volumed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-volumed')
-rw-r--r--xfce-extra/xfce4-volumed/Manifest1
-rw-r--r--xfce-extra/xfce4-volumed/metadata.xml11
-rw-r--r--xfce-extra/xfce4-volumed/xfce4-volumed-0.1.13.ebuild36
3 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-volumed/Manifest b/xfce-extra/xfce4-volumed/Manifest
new file mode 100644
index 000000000000..fa7f41cb5639
--- /dev/null
+++ b/xfce-extra/xfce4-volumed/Manifest
@@ -0,0 +1 @@
+DIST xfce4-volumed-0.1.13.tar.bz2 88518 SHA256 4ceca3a59b65630e849b89133f220def775009017ca2c3d689df27b7745040a9
diff --git a/xfce-extra/xfce4-volumed/metadata.xml b/xfce-extra/xfce4-volumed/metadata.xml
new file mode 100644
index 000000000000..dfc88d55b130
--- /dev/null
+++ b/xfce-extra/xfce4-volumed/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">xfce4-volumed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.13.ebuild b/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.13.ebuild
new file mode 100644
index 000000000000..9930d37516e5
--- /dev/null
+++ b/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Daemon to control volume up/down and mute keys"
+HOMEPAGE="https://launchpad.net/xfce4-volumed"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="alsa debug libnotify oss"
+
+COMMON_DEPEND="dev-libs/keybinder:0
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ >=xfce-base/xfconf-4.8
+ libnotify? ( x11-libs/libnotify )"
+RDEPEND="${COMMON_DEPEND}
+ alsa? ( media-plugins/gst-plugins-alsa:0.10 )
+ oss? ( media-plugins/gst-plugins-oss:0.10 )
+ !alsa? ( !oss? ( media-plugins/gst-plugins-meta:0.10 ) )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable debug)
+ $(use_with libnotify)
+ )
+
+ DOCS=( AUTHORS ChangeLog README THANKS )
+}