summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/camlp4/camlp4-4.04_p1.ebuild2
-rw-r--r--dev-ml/camlp4/camlp4-4.05_p1.ebuild2
-rw-r--r--dev-ml/camlp4/camlp4-4.08_p1.ebuild4
3 files changed, 7 insertions, 1 deletions
diff --git a/dev-ml/camlp4/camlp4-4.04_p1.ebuild b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
index 8bf8d05f279c..af8352a49da7 100644
--- a/dev-ml/camlp4/camlp4-4.04_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.04_p1.ebuild
@@ -33,6 +33,8 @@ src_configure() {
}
src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
emake byte
use ocamlopt && emake native
}
diff --git a/dev-ml/camlp4/camlp4-4.05_p1.ebuild b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
index fe6e0dc150a5..c7ad55154b10 100644
--- a/dev-ml/camlp4/camlp4-4.05_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.05_p1.ebuild
@@ -33,6 +33,8 @@ src_configure() {
}
src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
emake byte
use ocamlopt && emake native
}
diff --git a/dev-ml/camlp4/camlp4-4.08_p1.ebuild b/dev-ml/camlp4/camlp4-4.08_p1.ebuild
index 0c86d665428c..731b5432fd93 100644
--- a/dev-ml/camlp4/camlp4-4.08_p1.ebuild
+++ b/dev-ml/camlp4/camlp4-4.08_p1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,6 +34,8 @@ src_configure() {
}
src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
emake byte
use ocamlopt && emake native
}