summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild5
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild (renamed from sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild)5
5 files changed, 20 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild
index a64e6b0f2602..aed6e024eff7 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230810-r1.ebuild
@@ -169,8 +169,11 @@ src_install() {
EOF
fi
+ # We only install config files for ${CHOST} because unprefixed tools
+ # might be used for crosscompilation where e.g. PIE may not be supported.
+ # See bug #912237 and bug #901247.
local tool
- for tool in clang{,++,-cpp}; do
+ for tool in ${CHOST}-clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
@gentoo-common.cfg