summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/qpress/qpress-1.1-r1.ebuild (renamed from app-arch/qpress/qpress-1.1.ebuild)15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-arch/qpress/qpress-1.1.ebuild b/app-arch/qpress/qpress-1.1-r1.ebuild
index 21904daf9eb3..ba05bad121ce 100644
--- a/app-arch/qpress/qpress-1.1.ebuild
+++ b/app-arch/qpress/qpress-1.1-r1.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="A portable file archiver using QuickLZ algorithm"
HOMEPAGE="http://www.quicklz.com/"
SRC_URI="http://www.quicklz.com/${PN}-${PV/./}-source.zip"
+S="${WORKDIR}"
-LICENSE="GPL-3"
+LICENSE="GPL-1 GPL-2 GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
BDEPEND="app-arch/unzip"
-S="${WORKDIR}"
-
PATCHES=(
- "${FILESDIR}"/${PN}-1.1-fix-includes.patch
- "${FILESDIR}"/${PN}-1.1-fix-build-system.patch
+ "${FILESDIR}/${PN}-1.1-fix-includes.patch"
+ "${FILESDIR}/${PN}-1.1-fix-build-system.patch"
)
src_configure() {
@@ -28,5 +27,5 @@ src_configure() {
}
src_install() {
- dobin ${PN}
+ dobin qpress
}