summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cli_helpers/Manifest1
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.2.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/Manifest b/dev-python/cli_helpers/Manifest
index 2b454a836f67..8b79b216861d 100644
--- a/dev-python/cli_helpers/Manifest
+++ b/dev-python/cli_helpers/Manifest
@@ -1 +1,2 @@
DIST cli_helpers-2.2.0.tar.gz 34018 BLAKE2B c7dfe8b87db6312557b4ac87aa4eda77b94f12789fcd4a9e686cada47bd41601f5c357a77de4a1c6d550b2ea110b682da0a04edb312d26ecf281e6d323369462 SHA512 26d78227999e8bb37f58529ce29bbed1bc8d51c80f81127552fb1d1f880c476abdd43ca628c591ba50c0316b35d1df0541906bf902a7549f459da0e1200c8479
+DIST cli_helpers-2.2.1.tar.gz 34199 BLAKE2B 5fb5217321d92cd6c774337bdf444ad2a6120accfe32da08642a880a60f1bdb4c71f12657bd17c30f7b3f212216fad027ac9c786367563e01d58c54c15bf67b5 SHA512 4b4a8c3ab61ceeaa1986e5d9943b10351ff1b3339294a78ed740bff3bd555cace723e637d6627e26b832370583989aa2b0782f57949af2c1d504f93caceda2d8
diff --git a/dev-python/cli_helpers/cli_helpers-2.2.1.ebuild b/dev-python/cli_helpers/cli_helpers-2.2.1.ebuild
new file mode 100644
index 000000000000..40b1f9e1e864
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest