summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/mmslib/mmslib-0.97-r1.ebuild23
-rw-r--r--dev-php/mmslib/mmslib-0.97.ebuild24
2 files changed, 23 insertions, 24 deletions
diff --git a/dev-php/mmslib/mmslib-0.97-r1.ebuild b/dev-php/mmslib/mmslib-0.97-r1.ebuild
new file mode 100644
index 000000000000..ce52f868bffc
--- /dev/null
+++ b/dev-php/mmslib/mmslib-0.97-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Encoding, decoding, and sending of MMS:es"
+HOMEPAGE="https://www.hellkvist.org/software/#MMSLIB"
+SRC_URI="https://www.hellkvist.org/software/mmslib/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/php:*"
+
+src_install() {
+ insinto "/usr/share/php/mmslib"
+ doins mmslib.php
+
+ einstalldocs
+ use examples && dodoc -r samples content
+}
diff --git a/dev-php/mmslib/mmslib-0.97.ebuild b/dev-php/mmslib/mmslib-0.97.ebuild
deleted file mode 100644
index a622ac5b7a3b..000000000000
--- a/dev-php/mmslib/mmslib-0.97.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="library for encoding, decoding, and sending MMSes"
-HOMEPAGE="http://www.hellkvist.org/software/#MMSLIB"
-SRC_URI="http://www.hellkvist.org/software/mmslib/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-lang/php:*"
-
-src_install() {
- insinto "/usr/share/php/${PN}"
- doins mmslib.php
-
- dodoc README
- use examples && dodoc -r samples content
-}