summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/fastjet/fastjet-3.0.6-r1.ebuild56
1 files changed, 34 insertions, 22 deletions
diff --git a/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild b/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
index a7fec5728253..b5cfe12ace33 100644
--- a/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
+++ b/sci-physics/fastjet/fastjet-3.0.6-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
FORTRAN_NEEDED=plugins
-AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils fortran-2 flag-o-matic
+inherit autotools flag-o-matic fortran-2
DESCRIPTION="Fast implementation of several recombination jet algorithms"
HOMEPAGE="http://www.fastjet.fr/"
@@ -15,40 +14,53 @@ SRC_URI="http://www.fastjet.fr/repo/${P}.tar.gz"
LICENSE="GPL-2 QPL"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cgal doc examples +plugins static-libs"
+IUSE="cgal doc examples +plugins"
-RDEPEND="cgal? ( sci-mathematics/cgal )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- plugins? ( sci-physics/siscone:0= )"
+RDEPEND="
+ cgal? ( sci-mathematics/cgal:= )
+ plugins? ( sci-physics/siscone:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
PATCHES=( "${FILESDIR}"/${P}-system-siscone.patch )
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
use cgal && \
- has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
- local myeconfargs=(
- $(use_enable cgal)
- $(use_enable plugins allplugins)
+ has_version 'sci-mathematics/cgal[gmp]' && append-libs -lgmp
+
+ econf \
+ --disable-static \
+ $(use_enable cgal) \
+ $(use_enable plugins allplugins) \
$(use_enable plugins allcxxplugins)
- )
- autotools-utils_src_configure
}
src_compile() {
- autotools-utils_src_compile
+ default
+
if use doc; then
doxygen Doxyfile || die
+ HTML_DOCS=( html/. )
fi
}
src_install() {
- autotools-utils_src_install
- use doc && dohtml -r html/*
+ default
+
if use examples; then
- insinto /usr/share/doc/${PF}
- find example \
- -name Makefile -or Makefile.in -or Makefile.am -delete
- doins -r example/*
+ emake -C example maintainer-clean
+ find example -iname 'makefile*' -delete || die
+
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
}