summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild (renamed from sys-devel/clang-common/clang-common-17.0.0_rc2.ebuild)3
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild3
5 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-17.0.0_rc2.ebuild b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_rc2.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi