summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/automaton/Manifest1
-rw-r--r--dev-python/automaton/automaton-2.2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/automaton/Manifest b/dev-python/automaton/Manifest
index e79bf5f24c41..d6ee0640e2dd 100644
--- a/dev-python/automaton/Manifest
+++ b/dev-python/automaton/Manifest
@@ -1 +1,2 @@
DIST automaton-1.12.1.tar.gz 30350 BLAKE2B 2557cfe4be401080615a7e640d54184ac8213654711f75b12512c5fc689d96bfcb486770fe6bb1999a7af54f9c2e115a5a5bc2a45a25ab6e89d0030d4087d45f SHA512 c0b78d934f1c0768e1131db0640649254489afb8710098f68f61293746c80a2807edf82659d8fc9bd3812107dbb823e95055842c81477325f9ada65967ebf4e6
+DIST automaton-2.2.0.tar.gz 31629 BLAKE2B 1db3968bf2eb3dcec77edd6ca8f7ad6afd16d4e1a23fe3f5520ab78d8b78e817cf9bde14bb008e8740fdbd03e4b871361402283407133def0c15485962a210ce SHA512 9b773ac93f17542800b93e36ca8b42ab522b2fb1c72d36256a62a37463e49e9f299fbdb9d4507b7f2a6cf678bbcd16fc86be9d20720acf0b254e1bacca4c0300
diff --git a/dev-python/automaton/automaton-2.2.0.ebuild b/dev-python/automaton/automaton-2.2.0.ebuild
new file mode 100644
index 000000000000..adae746f38a5
--- /dev/null
+++ b/dev-python/automaton/automaton-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendly state machines for python."
+HOMEPAGE="https://pypi.org/project/automaton/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8.0[${PYTHON_USEDEP}]
+"