summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libixion/files/libixion-9999-spdlog-non-bundled-fmt.patch25
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild10
2 files changed, 32 insertions, 3 deletions
diff --git a/dev-libs/libixion/files/libixion-9999-spdlog-non-bundled-fmt.patch b/dev-libs/libixion/files/libixion-9999-spdlog-non-bundled-fmt.patch
new file mode 100644
index 000000000000..2cf5cb0a1848
--- /dev/null
+++ b/dev-libs/libixion/files/libixion-9999-spdlog-non-bundled-fmt.patch
@@ -0,0 +1,25 @@
+From 389c8def65406ae92077686a2e9095afebab28f4 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Wed, 24 Jul 2019 20:01:01 +0200
+Subject: [PATCH] Fix build when built against spdlog without bundled fmt
+
+---
+ src/libixion/dirty_cell_tracker.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libixion/dirty_cell_tracker.cpp b/src/libixion/dirty_cell_tracker.cpp
+index 42d338b..7e6e3cc 100644
+--- a/src/libixion/dirty_cell_tracker.cpp
++++ b/src/libixion/dirty_cell_tracker.cpp
+@@ -16,7 +16,7 @@
+ #include <limits>
+
+ #include <spdlog/spdlog.h>
+-#include <spdlog/fmt/bundled/ostream.h>
++#include <spdlog/fmt/ostr.h>
+
+ namespace ixion {
+
+--
+2.22.0
+
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index 860c13488fc6..92f685ee869e 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -23,12 +23,16 @@ IUSE="debug python static-libs +threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="
+RDEPEND="
dev-libs/boost:=
- >=dev-util/mdds-1.4.1:1=
+ >=dev-util/mdds-1.5.0:1=
python? ( ${PYTHON_DEPS} )
"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-libs/spdlog
+"
+
+PATCHES=( "${FILESDIR}"/${P}-spdlog-non-bundled-fmt.patch )
pkg_setup() {
use python && python-single-r1_pkg_setup