summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/buildbot-pkg/Manifest1
-rw-r--r--dev-util/buildbot-pkg/buildbot-pkg-3.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/buildbot-pkg/Manifest b/dev-util/buildbot-pkg/Manifest
index 5cc763c874af..83c9132ed765 100644
--- a/dev-util/buildbot-pkg/Manifest
+++ b/dev-util/buildbot-pkg/Manifest
@@ -6,3 +6,4 @@ DIST buildbot-pkg-3.0.2.tar.gz 4780 BLAKE2B 4cf0fad6413b3fbfab2637a08f9bee902281
DIST buildbot-pkg-3.1.0.tar.gz 4782 BLAKE2B 9107134a56eb27c3714ef5c66a610c44b21ae8080690f30147e6e9e0f592da08cc4e171eb588ea26d48aec269c8c73939ae19081133dc52aa8e4b3d3f9e1903e SHA512 8300031b01bf8d3d9e9508bbc101cfa48e516cfd4a797a04f93692a69b06e26cbe37ab4d712fa458e1aa39e1bb34567816fb5604258bf4e10c3359392aa3df6f
DIST buildbot-pkg-3.1.1.tar.gz 4784 BLAKE2B 47f19dc7872d5dbf45e53fd259e864d138a8a990801a4c87b3dc0b378477b4e424fbf2cdd6963dd92e3e33446770e72f23f9ea738796bbe1b0588b2a40c34974 SHA512 6f8309f62cd1fe2c7f61be58a79590eb28a53265819dbb28b229d122ecb3fc6513d9f47edd420add6e72aabf03784f7c9837f80ff9ae74f2474f72ce60aa876a
DIST buildbot-pkg-3.2.0.tar.gz 4777 BLAKE2B 0a20f1b16c5354a9f5f0ac6e2f91443af3c5754161324ca9b8c941ab3920e16e7bd31c8a4b7a655bb466f02718a22924e8a21e75efb505375daa01740cf0c2eb SHA512 e795e3198f61abbf6f7ec8eae3c98dc7bb054af2a0885a5529467e73c97d82d30ecb9a8c0b9daa2bac8b5fac72de63dc4dcd2a5e77df6006e50eef21c6f5f9fb
+DIST buildbot-pkg-3.3.0.tar.gz 4778 BLAKE2B 14bd3d7bd985e63a587313c26f35ada0fcb1fb25d0d1ff89f12714e8a6d29781e53c83b42bf4a0614d4543a7c24dbf4375cfa1600d95f050497523a84d42c177 SHA512 73b6d61c27336450e8a9df1094c8afbb7653b33517f6a55e35a1ef62125b969f8ddf0a94ad11c7da15489fca2e6a7ad853093a946945c511140e61f3341ad2c0
diff --git a/dev-util/buildbot-pkg/buildbot-pkg-3.3.0.ebuild b/dev-util/buildbot-pkg/buildbot-pkg-3.3.0.ebuild
new file mode 100644
index 000000000000..e78e9ab33131
--- /dev/null
+++ b/dev-util/buildbot-pkg/buildbot-pkg-3.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="BuildBot common www build tools for packaging releases"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-pkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+# No real integration tests for this pkg.
+# all tests are related to making releases and final checks for distribution
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -e "s:version=buildbot_pkg.getVersion(\".\"),:version=\"${MY_PV}\",:" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}