summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/rt-tests/rt-tests-1.8.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/rt-tests/rt-tests-1.8.ebuild b/dev-util/rt-tests/rt-tests-1.8.ebuild
index 994e2f56115f..f94e433d66c0 100644
--- a/dev-util/rt-tests/rt-tests-1.8.ebuild
+++ b/dev-util/rt-tests/rt-tests-1.8.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6..8} )
-inherit python-single-r1
+inherit python-single-r1 toolchain-funcs
DESCRIPTION="A collection of latency testing tools for the linux(-rt) kernel"
HOMEPAGE="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/about/"
@@ -27,6 +27,10 @@ src_prepare() {
use elibc_musl && eapply "${FILESDIR}/${P}-musl.patch"
}
+src_compile() {
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)"
+}
+
src_install() {
emake prefix=/usr DESTDIR="${D}" MAN_COMPRESSION=none install
python_fix_shebang "${ED}"