summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild5
-rw-r--r--sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild b/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild
index 864d31646209..a5af27f51d9c 100644
--- a/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild
+++ b/sci-mathematics/mathematica/mathematica-10.3.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit multilib xdg
+inherit desktop multilib xdg
DESCRIPTION="Wolfram Mathematica"
SRC_URI="Mathematica_${PV}_LINUX.sh"
@@ -62,12 +62,11 @@ src_install() {
done
# fix some embedded paths and install desktop files
- insinto /usr/share/applications
for filename in $(find "${D}/${M_TARGET}/SystemFiles/Installation" -name "wolfram-mathematica.desktop") ; do
echo Fixing "${filename}"
sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
- doins "${filename}"
+ domenu "${filename}"
done
# install mime types
diff --git a/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild b/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild
index 864d31646209..a5af27f51d9c 100644
--- a/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild
+++ b/sci-mathematics/mathematica/mathematica-12.1.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit multilib xdg
+inherit desktop multilib xdg
DESCRIPTION="Wolfram Mathematica"
SRC_URI="Mathematica_${PV}_LINUX.sh"
@@ -62,12 +62,11 @@ src_install() {
done
# fix some embedded paths and install desktop files
- insinto /usr/share/applications
for filename in $(find "${D}/${M_TARGET}/SystemFiles/Installation" -name "wolfram-mathematica.desktop") ; do
echo Fixing "${filename}"
sed -e "s:${S}::g" -e 's:^\t\t::g' -i "${filename}"
echo "Categories=Physics;Science;Engineering;2DGraphics;Graphics;" >> "${filename}"
- doins "${filename}"
+ domenu "${filename}"
done
# install mime types