summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/chrpath/chrpath-0.16.ebuild1
-rw-r--r--app-admin/chrpath/files/chrpath-0.16-solaris.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/app-admin/chrpath/chrpath-0.16.ebuild b/app-admin/chrpath/chrpath-0.16.ebuild
index 51137b39303e..323e49a75d97 100644
--- a/app-admin/chrpath/chrpath-0.16.ebuild
+++ b/app-admin/chrpath/chrpath-0.16.ebuild
@@ -17,6 +17,7 @@ IUSE="static-libs"
PATCHES=(
"${FILESDIR}"/${P}-multilib.patch
"${FILESDIR}"/${P}-testsuite-1.patch
+ "${FILESDIR}"/${P}-solaris.patch
)
src_prepare() {
diff --git a/app-admin/chrpath/files/chrpath-0.16-solaris.patch b/app-admin/chrpath/files/chrpath-0.16-solaris.patch
new file mode 100644
index 000000000000..5e1dd1957e8f
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-0.16-solaris.patch
@@ -0,0 +1,19 @@
+protos: add bswap macros for Solaris
+
+--- a/protos.h
++++ b/protos.h
+@@ -1,7 +1,14 @@
+ #ifndef PROTOS_H
+ #define PROTOS_H
+
++#if defined(__sun)
++#include <sys/byteorder.h>
++#define bswap_16(x) BSWAP_16(x)
++#define bswap_32(x) BSWAP_32(x)
++#define bswap_64(x) BSWAP_64(x)
++#else
+ #include <byteswap.h>
++#endif
+ #include <elf.h>
+ #include "config.h"
+