summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/widelands/files/widelands-1.0-boost-1.77.patch16
-rw-r--r--games-strategy/widelands/widelands-1.0.ebuild4
2 files changed, 20 insertions, 0 deletions
diff --git a/games-strategy/widelands/files/widelands-1.0-boost-1.77.patch b/games-strategy/widelands/files/widelands-1.0-boost-1.77.patch
new file mode 100644
index 000000000000..69c1cb8caf43
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-1.0-boost-1.77.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/808747
+
+https://github.com/widelands/widelands/commit/316eaea
+From: matthiakl <t-m.42@mailpost.spdns.org>
+Date: Sat, 14 Aug 2021 19:24:08 +0200
+Subject: [PATCH] Added missing direct incude (#5025)
+--- a/src/network/bufferedconnection.h
++++ b/src/network/bufferedconnection.h
+@@ -20,6 +20,7 @@
+ #ifndef WL_NETWORK_BUFFEREDCONNECTION_H
+ #define WL_NETWORK_BUFFEREDCONNECTION_H
+
++#include <map>
+ #include <memory>
+ #include <mutex>
+ #include <thread>
diff --git a/games-strategy/widelands/widelands-1.0.ebuild b/games-strategy/widelands/widelands-1.0.ebuild
index 6b04bc906390..1c8af8b6ba6c 100644
--- a/games-strategy/widelands/widelands-1.0.ebuild
+++ b/games-strategy/widelands/widelands-1.0.ebuild
@@ -42,6 +42,10 @@ BDEPEND="
${PYTHON_DEPS}
sys-devel/gettext"
+PATCHES=(
+ "${FILESDIR}"/${P}-boost-1.77.patch
+)
+
src_configure() {
CMAKE_BUILD_TYPE="Release"