summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
index 575154be6047..a39cfca35bc6 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl
dev-ml/findlib
+ >=dev-util/cmake-3.16
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
@@ -69,6 +70,8 @@ src_configure() {
-DLLVM_HOST_TRIPLE="${CHOST}"
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable go bindings
-DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
index bd90d5141e7c..317ad24d0e20 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl
dev-ml/findlib
+ >=dev-util/cmake-3.16
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
@@ -69,6 +70,8 @@ src_configure() {
-DLLVM_HOST_TRIPLE="${CHOST}"
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable go bindings
-DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
index 575154be6047..a39cfca35bc6 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl
dev-ml/findlib
+ >=dev-util/cmake-3.16
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
@@ -69,6 +70,8 @@ src_configure() {
-DLLVM_HOST_TRIPLE="${CHOST}"
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable go bindings
-DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND