summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/backintime/backintime-9999.ebuild')
-rw-r--r--app-backup/backintime/backintime-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 27931eda4e24..80c960450f88 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples qt5 test"
+IUSE="examples gui test"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -35,7 +35,7 @@ RDEPEND="
${DEPEND}
virtual/openssh
net-misc/rsync[xattr,acl]
- qt5? ( dev-python/PyQt5[gui,widgets] )
+ gui? ( dev-python/PyQt5[gui,widgets] )
"
BDEPEND="
sys-devel/gettext
@@ -46,7 +46,9 @@ BDEPEND="
)
"
-PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.3-no-compress-docs-examples.patch"
+)
src_prepare() {
default
@@ -60,12 +62,12 @@ src_prepare() {
src_configure() {
pushd common > /dev/null || die
# Not autotools
- ./configure --python3 --no-fuse-group || die
+ ./configure --python="${PYTHON}" --no-fuse-group || die
popd > /dev/null || die
- if use qt5 ; then
+ if use gui ; then
pushd qt > /dev/null || die
- ./configure --python3 || die
+ ./configure --python="${PYTHON}" || die
popd > /dev/null || die
fi
}
@@ -73,7 +75,7 @@ src_configure() {
src_compile() {
emake -C common
- if use qt5 ; then
+ if use gui ; then
emake -C qt
fi
}
@@ -88,7 +90,7 @@ src_test() {
src_install() {
emake -C common DESTDIR="${D}" install
- if use qt5 ; then
+ if use gui ; then
emake -C qt DESTDIR="${D}" install
fi