summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-proton/wine-proton-9999.ebuild')
-rw-r--r--app-emulation/wine-proton/wine-proton-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-emulation/wine-proton/wine-proton-9999.ebuild b/app-emulation/wine-proton/wine-proton-9999.ebuild
index 10f556feb152..512564eccefb 100644
--- a/app-emulation/wine-proton/wine-proton-9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-9999.ebuild
@@ -273,6 +273,9 @@ src_configure() {
filter-flags -Wl,--gc-sections # runtime issues (bug #931329)
use custom-cflags || strip-flags # can break in obscure ways at runtime
+ # broken with gcc-15's c23 default (TODO: try w/o occasionally, bug #943849)
+ append-cflags -std=gnu17
+
# wine uses linker tricks unlikely to work with non-bfd/lld (bug #867097)
# (do self test until https://github.com/gentoo/gentoo/pull/28355)
if [[ $(LC_ALL=C $(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) != @(LLD|GNU\ ld)* ]]