summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild b/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
index 84cc9ef221d0..d41e907ed14d 100644
--- a/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.16.2_pre2.ebuild
@@ -429,7 +429,16 @@ src_compile() {
local -x NO_WERROR=1
fi
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" build-tools ${myopt}
+ emake \
+ HOSTCC="$(tc-getBUILD_CC)" \
+ HOSTCXX="$(tc-getBUILD_CXX)" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ OBJDUMP="$(tc-getOBJDUMP)" \
+ RANLIB="$(tc-getRANLIB)" \
+ build-tools ${myopt}
if use doc; then
emake -C docs build