summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/wyrd/wyrd-1.4.4.ebuild')
-rw-r--r--app-misc/wyrd/wyrd-1.4.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/wyrd/wyrd-1.4.4.ebuild b/app-misc/wyrd/wyrd-1.4.4.ebuild
new file mode 100644
index 000000000000..fad37811a3ec
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://pessimization.com/software/wyrd/"
+SRC_URI="http://pessimization.com/software/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="unicode"
+
+DEPEND=">=dev-lang/ocaml-3.08
+ sys-libs/ncurses[unicode?]
+ >=app-misc/remind-03.01"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ econf \
+ $(use_enable unicode utf8)
+}
+
+src_install() {
+ export STRIP_MASK="/usr/bin/wyrd"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog || die "dodoc failed"
+ dohtml doc/manual.html || die "dohtml failed"
+}