summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/liblangtag')
-rw-r--r--app-text/liblangtag/Manifest3
-rw-r--r--app-text/liblangtag/files/liblangtag-0.5.1-gcc45.patch30
-rw-r--r--app-text/liblangtag/files/liblangtag-0.5.6-musl.patch25
-rw-r--r--app-text/liblangtag/liblangtag-0.5.1.ebuild45
-rw-r--r--app-text/liblangtag/liblangtag-0.5.2.ebuild41
-rw-r--r--app-text/liblangtag/liblangtag-0.5.6.ebuild43
-rw-r--r--app-text/liblangtag/metadata.xml8
7 files changed, 195 insertions, 0 deletions
diff --git a/app-text/liblangtag/Manifest b/app-text/liblangtag/Manifest
new file mode 100644
index 000000000000..ab22ef89ef29
--- /dev/null
+++ b/app-text/liblangtag/Manifest
@@ -0,0 +1,3 @@
+DIST liblangtag-0.5.1.tar.bz2 651785 SHA256 c3dd456762cd0b5fd1687f066c4bdf253d70b14729851b9cd05936a1cb46923b SHA512 006ed5b8621bfc4330589eeba8581dd2214a29c985f782b0c123012105ac6ea447f1d7593daec86b0126daf7929e6845208c633c63df67beca2d6201a6961bbf WHIRLPOOL 80f48834b00ba7732f07a7e88ae092a3f0f0168c3de176ad0544e130b8e0c3991a169ed4d502cdc9aff0af1fe3df43ac961d4c8517b9240b9934ea901c0626e5
+DIST liblangtag-0.5.2.tar.bz2 658800 SHA256 2b8dc5fa86486a1277c64e9b429eaf8ce0fcbef473b9123bb0374b711848f1c3 SHA512 73a40fbdef7820c3e1556b242e06e24040d048f62be8f9aeced0f12d0e606dfd8d49eb740bda4f0b07566c3d963d249c2440dbc9e865e1a3a11eb4fffcaa33a7 WHIRLPOOL fd04e243e5069723666acb1ed58fff2f33455916f76bfd871ef59de0ebd6b0ae392527bff13be09aab120bf72ab3b3af25b031cbb6097f04c3922652e0777e6a
+DIST liblangtag-0.5.6.tar.bz2 668949 SHA256 5cdec61f4ef8d4b1a198682fcdd17e88cb293549af5878d6ee4bdd55d129bd84 SHA512 60297d79b20c72a0ebf5fd685efbcb3eb2d40461cfe532fd5e4f2193c81c9037b8c69f9cb0977f640a7d8f315cb14508de9455334115b152ed30d23f91d75e52 WHIRLPOOL 0805c9dcde9802818ec4e19309eb9b09e4dfe77627fefcb190203110b9ec133083d48c0474171368e1b061612f1e06bc936d1dc1ad1ad551dd276afe3db26fb5
diff --git a/app-text/liblangtag/files/liblangtag-0.5.1-gcc45.patch b/app-text/liblangtag/files/liblangtag-0.5.1-gcc45.patch
new file mode 100644
index 000000000000..61bd1d041f7c
--- /dev/null
+++ b/app-text/liblangtag/files/liblangtag-0.5.1-gcc45.patch
@@ -0,0 +1,30 @@
+From 4a5ec00d229d9ccf293dc21ce64eb42de7e8118c Mon Sep 17 00:00:00 2001
+From: Jung-uk Kim <jkim@FreeBSD.org>
+Date: Thu, 9 May 2013 15:59:35 -0400
+Subject: [PATCH] Fix duplicate typedef introduced in 57c47aa.
+
+---
+ liblangtag/lt-trie.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/liblangtag/lt-trie.c b/liblangtag/lt-trie.c
+index d2162c9..301a6da 100644
+--- a/liblangtag/lt-trie.c
++++ b/liblangtag/lt-trie.c
+@@ -33,11 +33,11 @@ struct _lt_trie_t {
+ lt_iter_tmpl_t parent;
+ lt_trie_node_t *root;
+ };
+-typedef struct _lt_trie_iter_t {
++struct _lt_trie_iter_t {
+ lt_iter_t parent;
+ lt_list_t *stack;
+ lt_string_t *pos_str;
+-} lt_trie_iter_t;
++};
+
+ /*< private >*/
+ static lt_trie_node_t *
+--
+1.8.2.3
+
diff --git a/app-text/liblangtag/files/liblangtag-0.5.6-musl.patch b/app-text/liblangtag/files/liblangtag-0.5.6-musl.patch
new file mode 100644
index 000000000000..e6d1d1184cea
--- /dev/null
+++ b/app-text/liblangtag/files/liblangtag-0.5.6-musl.patch
@@ -0,0 +1,25 @@
+From 6ebf5709810983dca570d9f8873293b01b4a49bc Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Mon, 20 Apr 2015 10:28:29 +0900
+Subject: [PATCH] add missing sys/types.h in lt-string.h required to build musl
+ libc to satisfy ssize_t. (fixes issue#12)
+
+---
+ liblangtag/lt-string.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/liblangtag/lt-string.h b/liblangtag/lt-string.h
+index 15724fc..c784430 100644
+--- a/liblangtag/lt-string.h
++++ b/liblangtag/lt-string.h
+@@ -18,6 +18,7 @@
+ #define __LT_STRING_H__
+
+ #include <liblangtag/lt-macros.h>
++#include <sys/types.h>
+
+ LT_BEGIN_DECLS
+
+--
+2.4.1
+
diff --git a/app-text/liblangtag/liblangtag-0.5.1.ebuild b/app-text/liblangtag/liblangtag-0.5.1.ebuild
new file mode 100644
index 000000000000..d14e7f624223
--- /dev/null
+++ b/app-text/liblangtag/liblangtag-0.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="An interface library to access tags for identifying languages"
+HOMEPAGE="http://tagoh.bitbucket.org/liblangtag/"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="introspection static-libs test"
+
+RDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ sys-devel/gettext
+ test? ( dev-libs/check )"
+
+# Upstream expect liblangtag to be installed when one runs tests...
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc45.patch"
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable introspection)
+ $(use_enable test)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+}
diff --git a/app-text/liblangtag/liblangtag-0.5.2.ebuild b/app-text/liblangtag/liblangtag-0.5.2.ebuild
new file mode 100644
index 000000000000..818d90f5e1aa
--- /dev/null
+++ b/app-text/liblangtag/liblangtag-0.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="An interface library to access tags for identifying languages"
+HOMEPAGE="http://tagoh.bitbucket.org/liblangtag/"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="introspection static-libs test"
+
+RDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ sys-devel/gettext
+ test? ( dev-libs/check )"
+
+# Upstream expect liblangtag to be installed when one runs tests...
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable introspection)
+ $(use_enable test)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+}
diff --git a/app-text/liblangtag/liblangtag-0.5.6.ebuild b/app-text/liblangtag/liblangtag-0.5.6.ebuild
new file mode 100644
index 000000000000..8eace5161d9e
--- /dev/null
+++ b/app-text/liblangtag/liblangtag-0.5.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="An interface library to access tags for identifying languages"
+HOMEPAGE="http://tagoh.bitbucket.org/liblangtag/"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-3 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="introspection static-libs test"
+
+RDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ sys-devel/gettext
+ test? ( dev-libs/check )"
+
+# Upstream expect liblangtag to be installed when one runs tests...
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.6-musl.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable introspection)
+ $(use_enable test)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+}
diff --git a/app-text/liblangtag/metadata.xml b/app-text/liblangtag/metadata.xml
new file mode 100644
index 000000000000..5aa863f210a2
--- /dev/null
+++ b/app-text/liblangtag/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ </use>
+</pkgmetadata>