summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/odbtp')
-rw-r--r--dev-db/odbtp/Manifest1
-rw-r--r--dev-db/odbtp/files/odbtp-1.1.4-amd64.patch11
-rw-r--r--dev-db/odbtp/metadata.xml10
-rw-r--r--dev-db/odbtp/odbtp-1.1.4.ebuild39
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/odbtp/Manifest b/dev-db/odbtp/Manifest
new file mode 100644
index 000000000000..e6e267ae640a
--- /dev/null
+++ b/dev-db/odbtp/Manifest
@@ -0,0 +1 @@
+DIST odbtp-1.1.4.tar.gz 1049975 SHA256 c4f4e0b01610d0e547dfe70e9e2184fc35c8944a44be6a70ec8c8fc28dffe705 SHA512 4b87c8733fc1f017546024901874b0ea2f410646ef39f9581cc170773639077c3f885813550422966e8797489c66b32b75de85fa658e3bb84da285b96c0a7b70 WHIRLPOOL b5443d5639e9d1f938d3708153cdc10a92ba6c2f8e4a1615c897ac05aebb88d59903ddde59092130373abcf8daefe59086c6eac9f686dce753be03cd68012d4a
diff --git a/dev-db/odbtp/files/odbtp-1.1.4-amd64.patch b/dev-db/odbtp/files/odbtp-1.1.4-amd64.patch
new file mode 100644
index 000000000000..1ba2cb3b71e5
--- /dev/null
+++ b/dev-db/odbtp/files/odbtp-1.1.4-amd64.patch
@@ -0,0 +1,11 @@
+--- odbtp-1.1.4/odbtp.h.old 2006-11-05 21:29:33.000000000 +0100
++++ odbtp-1.1.4/odbtp.h 2006-11-05 21:29:44.000000000 +0100
+@@ -22,7 +22,7 @@
+ #define _ODBTP_H_
+
+ /* The below line must be uncommented for 64-bit systems, such as Tru64. */
+-/* #define _C_LONG_64_ 1 */
++#define _C_LONG_64_ 1
+
+ #define ODBTP_LIB_VERSION "1.1.4"
+
diff --git a/dev-db/odbtp/metadata.xml b/dev-db/odbtp/metadata.xml
new file mode 100644
index 000000000000..63c0c25310b1
--- /dev/null
+++ b/dev-db/odbtp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">odbtp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/odbtp/odbtp-1.1.4.ebuild b/dev-db/odbtp/odbtp-1.1.4.ebuild
new file mode 100644
index 000000000000..8604f7e45aed
--- /dev/null
+++ b/dev-db/odbtp/odbtp-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Fast, efficient TCP/IP protocol for connecting to Win32-based databases from any platform"
+HOMEPAGE="http://odbtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/odbtp/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patch according to the README.64bitOS
+ use amd64 && epatch "${FILESDIR}/${P}-amd64.patch"
+}
+
+src_compile() {
+ # respect $CC (bug #243768)
+ tc-export CC
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # Install various documentation
+ dodoc AUTHORS INSTALL NEWS README*
+ if use doc ; then
+ dohtml -r docs/*
+ fi
+}