summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/slony1/files')
-rw-r--r--dev-db/slony1/files/slony1-2.1.1-ldflags.patch29
-rw-r--r--dev-db/slony1/files/slony1-2.1.2-ldflags.patch17
-rw-r--r--dev-db/slony1/files/slony1.conf12
-rwxr-xr-xdev-db/slony1/files/slony1.init37
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-db/slony1/files/slony1-2.1.1-ldflags.patch b/dev-db/slony1/files/slony1-2.1.1-ldflags.patch
new file mode 100644
index 000000000000..35452ad3b852
--- /dev/null
+++ b/dev-db/slony1/files/slony1-2.1.1-ldflags.patch
@@ -0,0 +1,29 @@
+diff -Naur a/Makefile.global.in b/Makefile.global.in
+--- a/Makefile.global.in 2012-01-25 14:13:40.000000000 -0500
++++ b/Makefile.global.in 2012-02-22 06:14:05.240047000 -0500
+@@ -80,7 +80,7 @@
+ subdir=$(slony_subdir)
+
+ override CPPFLAGS := -I${pgincludeserverdir} -I${pgincludedir} $(CPPFLAGS)
+-LDFLAGS = -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
++override LDFLAGS += -L${pglibdir} -L${pgpkglibdir} -lpq @NLSLIB@
+
+ ifeq ($(GCC), yes)
+ CFLAGS += -Wall -Wmissing-prototypes -Wmissing-declarations
+diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+--- a/makefiles/Makefile.linux 2012-01-25 14:13:40.000000000 -0500
++++ b/makefiles/Makefile.linux 2012-02-22 06:15:45.652523000 -0500
+@@ -12,9 +12,9 @@
+ endif
+
+ %.so: %.o
+- $(CC) -shared -o $@ $<
++ $(CC) $(LDFLAGS) -shared -o $@ $<
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
+
+-sqlmansect = 7
+\ No newline at end of file
++sqlmansect = 7
diff --git a/dev-db/slony1/files/slony1-2.1.2-ldflags.patch b/dev-db/slony1/files/slony1-2.1.2-ldflags.patch
new file mode 100644
index 000000000000..038b2ee20fb5
--- /dev/null
+++ b/dev-db/slony1/files/slony1-2.1.2-ldflags.patch
@@ -0,0 +1,17 @@
+diff -Naur a/makefiles/Makefile.linux b/makefiles/Makefile.linux
+--- a/makefiles/Makefile.linux 2012-01-25 14:13:40.000000000 -0500
++++ b/makefiles/Makefile.linux 2012-02-22 06:15:45.652523000 -0500
+@@ -12,9 +12,9 @@
+ endif
+
+ %.so: %.o
+- $(CC) -shared -o $@ $<
++ $(CC) $(LDFLAGS) -shared -o $@ $<
+
+ %.o: %.c
+- $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -c -o $@ $<
+
+-sqlmansect = 7
+\ No newline at end of file
++sqlmansect = 7
diff --git a/dev-db/slony1/files/slony1.conf b/dev-db/slony1/files/slony1.conf
new file mode 100644
index 000000000000..219092bd1294
--- /dev/null
+++ b/dev-db/slony1/files/slony1.conf
@@ -0,0 +1,12 @@
+# /etc/conf.d/slony1:
+# $Id$
+
+# Configuration file for /etc/init.d/slony1
+
+USER=postgres
+CLUSTER=your_cluster_name
+DBUSER=postgres
+DBNAME=your_database_name
+DBHOST=localhost
+LOGFILE=/var/lib/postgresql/data/slony1.log
+LOGLEVEL=1 # 1(minimum)..4(maximum)
diff --git a/dev-db/slony1/files/slony1.init b/dev-db/slony1/files/slony1.init
new file mode 100755
index 000000000000..1e1443b0ac2f
--- /dev/null
+++ b/dev-db/slony1/files/slony1.init
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need postgresql
+}
+
+start() {
+ ebegin "Starting slony1"
+ /usr/bin/slon -p /var/run/slony1.pid -d $LOGLEVEL $CLUSTER "dbname=$DBNAME user=$DBUSER host=$DBHOST" >> $LOGFILE 2>&1 &
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "/var/run/slony1.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $LOGFILE"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping slony1"
+ kill `cat /var/run/slony1.pid`
+ eend $?
+}
+