summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-oauth2/go-oauth2-9999.ebuild')
-rw-r--r--dev-go/go-oauth2/go-oauth2-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-go/go-oauth2/go-oauth2-9999.ebuild b/dev-go/go-oauth2/go-oauth2-9999.ebuild
new file mode 100644
index 000000000000..9fb295ad4390
--- /dev/null
+++ b/dev-go/go-oauth2/go-oauth2-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=golang.org/x/oauth2
+EGO_SRC=golang.org/x/oauth2
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="b5adcc2dcdf009d0391547edc6ecbaff889f5bb9"
+ SRC_URI="https://github.com/golang/oauth2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go client implementation for OAuth 2.0 spec"
+HOMEPAGE="https://godoc.org/golang.org/x/oauth2"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND="dev-go/go-net:="
+RDEPEND=""