summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/isa-l/isa-l-2.30.0.ebuild')
-rw-r--r--dev-libs/isa-l/isa-l-2.30.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/isa-l/isa-l-2.30.0.ebuild b/dev-libs/isa-l/isa-l-2.30.0.ebuild
new file mode 100644
index 000000000000..641f57997e4b
--- /dev/null
+++ b/dev-libs/isa-l/isa-l-2.30.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Intelligent Storage Acceleration Library"
+HOMEPAGE="https://github.com/intel/isa-l"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+#DEPEND=""
+#RDEPEND=""
+# TODO: yasm version to support avx512?
+BDEPEND="amd64? ( >=dev-lang/nasm-2.15 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.30.0_makefile-no-D.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}