summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libixion/files/libixion-0.9.1-python-optional.patch')
-rw-r--r--dev-libs/libixion/files/libixion-0.9.1-python-optional.patch96
1 files changed, 61 insertions, 35 deletions
diff --git a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
index a4e7239568a2..df945abc3928 100644
--- a/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
+++ b/dev-libs/libixion/files/libixion-0.9.1-python-optional.patch
@@ -1,34 +1,48 @@
-commit 59c360c9fe438a2805d65decc6c7889bc99a7747
-Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun May 31 10:14:17 2015 +0200
-
- python: Make it optional
-
- python bindings are built unless disabled
-
-diff --git a/configure.ac b/configure.ac
-index 03f6120..1c7d8b2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -15,7 +15,6 @@ AC_PREREQ([2.63])
+--- a/configure.ac 2016-02-06 17:08:05.505990463 +0100
++++ b/configure.ac 2016-02-06 17:08:42.316530268 +0100
+@@ -15,18 +15,13 @@
AC_INIT([libixion], [ixion_version])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 foreign dist-bzip2 dist-xz])
-AM_PATH_PYTHON(2.7.0)
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
- AC_ARG_WITH(hash-container-compat,
-@@ -28,6 +27,9 @@ AC_ARG_WITH(mdds-include-path,
- AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
- ,)
-
+-AC_ARG_WITH(hash-container-compat,
+-[
+- --with-hash-container-compat use std::hash_foo instead of boost::unordered_foo
+-],
+-,with_hash_container_compat=no)
+-
+-AC_ARG_WITH(mdds-include-path,
+- AS_HELP_STRING([--with-mdds-include-path], [specify include path for mdds headers.])
+-,)
+AC_ARG_ENABLE([python],
-+ AS_HELP_STRING([--disable-python], [Disable python bindings]))
-+
++ [AS_HELP_STRING([--disable-python], [Disable python bindings])],
++ [enable_python="$enableval"],
++ [enable_python=yes]
++)
+
IXION_API_VERSION=ixion_api_version
IXION_MAJOR_VERSION=ixion_major_version
- IXION_MINOR_VERSION=ixion_minor_version
-@@ -82,7 +84,11 @@ fi
+@@ -66,23 +61,19 @@
+ AC_FUNC_STRTOD
+ AC_CHECK_FUNCS([gettimeofday])
+
+-CPPFLAGS="$CPPFLAGS -D_REENTRANT -DMDDS_HASH_CONTAINER_BOOST"
++CPPFLAGS="$CPPFLAGS -D_REENTRANT"
+
+-AC_MSG_CHECKING([whether to turn on hash container compatibility])
+-if test "z$with_hash_container_compat" = "zno"; then
+- AC_MSG_RESULT([no])
+- BOOST_REQUIRE([1.36])
+- BOOST_UNORDERED
+-else
+- AC_MSG_RESULT([yes])
+- DEFINES="$DEFINES -D_IXION_HASH_CONTAINER_COMPAT"
+-fi
++BOOST_REQUIRE([1.36])
+
+ # Check for mdds.
PKG_CHECK_MODULES([MDDS],[mdds >= 0.12.0])
# Check for python.
@@ -37,20 +51,32 @@ index 03f6120..1c7d8b2 100644
+ AM_PATH_PYTHON(2.7.0)
+ PKG_CHECK_MODULES([PYTHON], [python >= 0.27.1])
+])
-+AM_CONDITIONAL([PYTHON], [test "x$enable_python" != "xno"])
++AM_CONDITIONAL([BUILD_PYTHON], [test "x$enable_python" != "xno"])
CPPFLAGS="$CPPFLAGS -g -Os -fvisibility=hidden"
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 6e138a4..cd912ab 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,4 +1,7 @@
--SUBDIRS = libixion python
-+SUBDIRS = libixion
-+if PYTHON
-+ SUBDIRS += python
-+endif
-
- AM_CPPFLAGS = -I$(top_srcdir)/include $(MDDS_CFLAGS)
+@@ -101,3 +92,10 @@
+ src/libixion/constants.inl
+ src/python/Makefile])
+ AC_OUTPUT
++
++AC_MSG_NOTICE([
++==============================================================================
++Build configuration:
++ python: $enable_python
++==============================================================================
++])
+--- a/src/python/Makefile.am 2016-02-06 17:08:12.138907540 +0100
++++ b/src/python/Makefile.am 2016-02-06 17:08:38.034583800 +0100
+@@ -1,3 +1,5 @@
++if BUILD_PYTHON
++
+ pyexec_LTLIBRARIES = ixion.la
+ ixion_la_SOURCES = \
+ document.hpp \
+@@ -16,3 +18,5 @@
+ AM_TESTS_ENVIRONMENT = PYTHONPATH=.libs$${PYTHONPATH:+:$${PYTHONPATH}}; export PYTHONPATH;
+ TESTS = ../../test/ixion-python-test.py
++
++endif