summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libspt/libspt-1.1-r2.ebuild')
-rw-r--r--dev-libs/libspt/libspt-1.1-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libspt/libspt-1.1-r2.ebuild b/dev-libs/libspt/libspt-1.1-r2.ebuild
new file mode 100644
index 000000000000..ce0f5d6e9b5b
--- /dev/null
+++ b/dev-libs/libspt/libspt-1.1-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit base
+
+DESCRIPTION="Library for handling root privilege"
+HOMEPAGE="http://www.j10n.org/libspt/index.html"
+SRC_URI="http://www.j10n.org/libspt/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/libspt-werror.patch" \
+ "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc CHANGES
+}