summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/input-pad/files/input-pad-Wreturn-type.patch23
-rw-r--r--dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild5
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-libs/input-pad/files/input-pad-Wreturn-type.patch b/dev-libs/input-pad/files/input-pad-Wreturn-type.patch
new file mode 100644
index 000000000000..2e50f8bce2b0
--- /dev/null
+++ b/dev-libs/input-pad/files/input-pad-Wreturn-type.patch
@@ -0,0 +1,23 @@
+--- a/input-pad/window-gtk.c
++++ b/input-pad/window-gtk.c
+@@ -5462,7 +5462,7 @@
+
+ app = INPUT_PAD_GTK_APPLICATION (window_data);
+
+- g_return_if_fail (app->window != NULL);
++ g_return_val_if_fail (app->window != NULL, 0);
+
+ return gtk_widget_get_visible (GTK_WIDGET (app->window));
+ }
+@@ -5661,8 +5661,9 @@
+ {
+ InputPadGtkApplication *app;
+
+- g_return_if_fail (window_data != NULL &&
+- INPUT_PAD_IS_GTK_APPLICATION (window_data));
++ g_return_val_if_fail (window_data != NULL &&
++ INPUT_PAD_IS_GTK_APPLICATION (window_data),
++ -1);
+
+ app = INPUT_PAD_GTK_APPLICATION (window_data);
+
diff --git a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
index 6675baa16c60..2294addb77a2 100644
--- a/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
+++ b/dev-libs/input-pad/input-pad-1.0.99_pre20140916.ebuild
@@ -33,7 +33,10 @@ BDEPEND="dev-util/intltool
virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-man.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-Wreturn-type.patch
+ "${FILESDIR}"/${PN}-man.patch
+)
src_prepare() {
default