summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-redis/ocaml-redis-0.3.4.ebuild')
-rw-r--r--dev-ml/ocaml-redis/ocaml-redis-0.3.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis/ocaml-redis-0.3.4.ebuild b/dev-ml/ocaml-redis/ocaml-redis-0.3.4.ebuild
new file mode 100644
index 000000000000..f69ee04b772b
--- /dev/null
+++ b/dev-ml/ocaml-redis/ocaml-redis-0.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Redis bindings for OCaml"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-re:=
+ dev-ml/uuidm:=
+ dev-ml/lwt:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ jbuilder build -p redis || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ redis.install || die
+}