summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Feed-Find/Feed-Find-0.70.0-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-perl/Feed-Find/Feed-Find-0.70.0-r1.ebuild b/dev-perl/Feed-Find/Feed-Find-0.70.0-r1.ebuild
index 5fdbe3431b9a..d2a6ad7b99a7 100644
--- a/dev-perl/Feed-Find/Feed-Find-0.70.0-r1.ebuild
+++ b/dev-perl/Feed-Find/Feed-Find-0.70.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=BTROTT
-MODULE_VERSION=0.07
+DIST_AUTHOR=BTROTT
+DIST_VERSION=0.07
inherit perl-module
DESCRIPTION="Syndication feed auto-discovery"
@@ -21,4 +21,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-SRC_TEST=online
+DIST_TEST=online
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}