summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/calver/calver-2022.06.26.ebuild')
-rw-r--r--dev-python/calver/calver-2022.06.26.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/calver/calver-2022.06.26.ebuild b/dev-python/calver/calver-2022.06.26.ebuild
new file mode 100644
index 000000000000..4ce266d2fb49
--- /dev/null
+++ b/dev-python/calver/calver-2022.06.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools extension for CalVer package versions"
+HOMEPAGE="
+ https://github.com/di/calver/
+ https://pypi.org/project/calver/
+"
+SRC_URI="
+ https://github.com/di/calver/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest