summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/commonmark/commonmark-0.5.4.ebuild')
-rw-r--r--dev-python/commonmark/commonmark-0.5.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/commonmark/commonmark-0.5.4.ebuild b/dev-python/commonmark/commonmark-0.5.4.ebuild
new file mode 100644
index 000000000000..630fd63052eb
--- /dev/null
+++ b/dev-python/commonmark/commonmark-0.5.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN=CommonMark
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+# unrestrict for versions >= 0.7.2
+RESTRICT=test
+
+python_test() {
+ LC_ALL='en_US.utf8' LC_CTYPE='en_US.utf8' LANG=en_US.utf8 PYTHONIOENCODING=UTF-8 \
+ esetup.py test
+}