summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fonttools/fonttools-4.1.0.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-4.1.0.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/fonttools/fonttools-4.1.0.ebuild b/dev-python/fonttools/fonttools-4.1.0.ebuild
index 3e2e55324904..7501d28d43e7 100644
--- a/dev-python/fonttools/fonttools-4.1.0.ebuild
+++ b/dev-python/fonttools/fonttools-4.1.0.ebuild
@@ -29,6 +29,22 @@ DEPEND="${RDEPEND}
app-arch/zopfli
)"
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
# virtualx used when matplotlib is installed causing plot module tests to run
virtx pytest -vv Tests fontTools || die "pytest failed"