summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2024.3.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 7ac09907d8d7..1d4fa31d3e78 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,2 +1,3 @@
DIST filesystem_spec-2024.2.0.gh.tar.gz 424600 BLAKE2B 548f77229dd936437cbafcd4e8df2a5c25e6244ba5c95553cb84eabbb6d8c2aa16313896b4aecbb6c921d01f84c6c5517b13a2cf1552cac0fa29da8034873143 SHA512 ca8c7c448984ecd9b128608f2c028cf32baf3cda3f22addde80c3bef5c1e5644e010b739fb5d28dc951151fdafb4006def080e8c2c769179b1d145ad6e2f9370
DIST filesystem_spec-2024.3.0.gh.tar.gz 426296 BLAKE2B 815b8004f5f04e7c831d4b31e0d667b63f9dc13d2ccbb5cd3e33292ec75a8952e4eceaa9e1f2547de3ab53111e1154c9ca36b4e48ea21e3235a409ee00e409b6 SHA512 f6b05e5724cb640a3526b37f6368327788cf87bb9e4a523f79af846aa682dbd193b1699854e8f7c57849ba7a6805a422d56aad77049e4500a5ca2c0966ab183e
+DIST filesystem_spec-2024.3.1.gh.tar.gz 426712 BLAKE2B 9e9c60f581872559bd667e8e3fadcb5c4c56a727901ffc2328b67da6a4553ae2e4981f143838532faa59deb9b3f3926e1e2f0b2dd86daf49f93a1811d4e668a4 SHA512 6b93543b729eae898a71fb0249ed69973cb1d2dfcf0feac7d40fb69b40e1109739819acbec9f239023b8a5eaaba01377215458cb5c4c806741ed319433d8f570
diff --git a/dev-python/fsspec/fsspec-2024.3.1.ebuild b/dev-python/fsspec/fsspec-2024.3.1.ebuild
new file mode 100644
index 000000000000..68c6f4a4b1af
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.3.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+ # requires s3fs
+ fsspec/implementations/tests/test_local.py::test_urlpath_inference_errors
+ fsspec/tests/test_core.py::test_mismatch
+ # requires pyarrow, fastparquet
+ fsspec/implementations/tests/test_reference.py::test_df_single
+ fsspec/implementations/tests/test_reference.py::test_df_multi
+ )
+
+ local EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+ # unhappy about dev-python/fuse-python (?)
+ fsspec/tests/test_fuse.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}