summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.14.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index e76025678a58..68753213b6f4 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-3.12.0.tar.gz 59539 BLAKE2B f484f90515af5306ed56fda516ac5fa6ea2b6acf5fdde9b3e6f40bd147cc19b4934819d169b1de96d6feaf1170a57556f43308f4bb82af680a7acbd2b6913642 SHA512 ccbbf2467725d1ea75b1d90468da2369f41de7cc0c15c67e27efbfee8d35bfeeba4c959752980561978d37fb603e1b7b17400b9e983876daa19456c790b492ec
DIST prettytable-3.13.0.tar.gz 61087 BLAKE2B 6f6a64c06dd44090824cdb849c0e20bbd2a3d2ca80f243aabd732b63798a6370e64afe6ff66f4c936461ebef2329efdca9bdd6e028186856baf60e2f050e27d5 SHA512 97aa5b33491c244aa61f1042ad298e4df1effe004a6fa349d1ae1da27c4b89f7095377d214a789ba803c765ba16104acd5a6e80754a089dc5f8dc8c4d17b67fb
+DIST prettytable-3.14.0.tar.gz 61747 BLAKE2B 94bb7faa84f174c57b9bb6ddbed2438d00544ed3dabda5a88bf52205e37b646489a425e4b30cf254bd454b94a2ce6906d332ab6a9ea6d4f3c2960f46e9fd214f SHA512 9e3b5cc819b25e3731ad4b8a0809c631879c903733906177fe5b1668ea85ed025192ae0f1e0c8616a7eec51dfd9e15732a7e83c80e30549aad6a3fe768feae19
diff --git a/dev-python/prettytable/prettytable-3.14.0.ebuild b/dev-python/prettytable/prettytable-3.14.0.ebuild
new file mode 100644
index 000000000000..5e1bdad68b08
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/prettytable/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # remove the implicit dep on coverage
+ sed -i -e '/coverage/d' pyproject.toml || die
+}