summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py/py-1.4.26.ebuild')
-rw-r--r--dev-python/py/py-1.4.26.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/py/py-1.4.26.ebuild b/dev-python/py/py-1.4.26.ebuild
deleted file mode 100644
index bcc515eb9c60..000000000000
--- a/dev-python/py/py-1.4.26.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
-HOMEPAGE="http://pylib.readthedocs.org/ https://pypi.python.org/pypi/py"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-python_prepare_all() {
- sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test || die "testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}