summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyblake2')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3-r1.ebuild (renamed from dev-python/pyblake2/pyblake2-0.9.3.ebuild)5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3-r1.ebuild
index e72595ae78bb..9245471a8a72 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3-r1.ebuild
@@ -46,6 +46,11 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+python_configure_all() {
+ # reported to break stuff, https://bugs.gentoo.org/638428
+ append-flags -fno-tree-vectorize
+}
+
python_test() {
"${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
}