summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/typing/typing-3.5.2.2.ebuild')
-rw-r--r--dev-python/typing/typing-3.5.2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/typing/typing-3.5.2.2.ebuild b/dev-python/typing/typing-3.5.2.2.ebuild
new file mode 100644
index 000000000000..8377efeec160
--- /dev/null
+++ b/dev-python/typing/typing-3.5.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Type Hints for Python"
+HOMEPAGE="https://docs.python.org/3.5/library/typing.html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}