summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/ujson-5.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index c81d092a5c9b..44eb4fd7a47e 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1 +1,2 @@
DIST ujson-5.1.0.tar.gz 7128147 BLAKE2B edd5b944e98790f3b98c4e2dbeebd1bb058c7b10e07d7919d3354cc2bcc1c8398b5bea08d27cdad438f2aa4a5d340da377ca9ef9b4b03b3d5b0e3053787ee618 SHA512 8988696918402f9e540e878eeafb2d29ed2819d4fa6ca801251a0411981eab2663eb16599a37ffa531e2e036706bd27cb1467bac17c33579e010d106da488951
+DIST ujson-5.2.0.tar.gz 7135591 BLAKE2B 1207e1eae65f859018bbb7a868c2b2010c0e4b41214ea63c1aef00a41600f69e941a1a02d22f1702f3974a3f12e90a731717681e6e9a9e782fc49716b4b13cef SHA512 c0ef90bdaa2d5e02109ea3e01288ff9ab4e4bd865ea0a33d915de2878cb13a04f24fe278f86582e042b430e6b20077f2b337d6a4349777a803e9725666952fd6
diff --git a/dev-python/ujson/ujson-5.2.0.ebuild b/dev-python/ujson/ujson-5.2.0.ebuild
new file mode 100644
index 000000000000..e6180b1cf01d
--- /dev/null
+++ b/dev-python/ujson/ujson-5.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/double-conversion:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # TODO: using system dc breaks tests
+ #export UJSON_BUILD_DC_LIBS="-ldouble-conversion"
+ export UJSON_BUILD_NO_STRIP=1
+}