summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/websocket-client')
-rw-r--r--dev-python/websocket-client/Manifest1
-rw-r--r--dev-python/websocket-client/websocket-client-1.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/websocket-client/Manifest b/dev-python/websocket-client/Manifest
index af0dfbbae5a2..b64b6d90876c 100644
--- a/dev-python/websocket-client/Manifest
+++ b/dev-python/websocket-client/Manifest
@@ -1 +1,2 @@
DIST websocket-client-1.4.2.tar.gz 49113 BLAKE2B d1d25d7066512ae5a8fa189b22ad320331b3d34e6ae953a29b7b5644065a9d60ffd6743bae6e769f356b7294374690fba103ee42ed59f5f9b213dfeda7f038af SHA512 4003a6b387096a738e9b9f76129b954bbc208b8b75c6ba9d6f0dade82078645109f985164ce25c1a600e630833f7187d51d6236997d6c72315d206e91f1aae7a
+DIST websocket-client-1.5.0.tar.gz 49931 BLAKE2B 03911ba7c147e19dab2fe3198ead34f1dc7d7ac970f33d20cb1eaa9ade0924be873c8ccc585326a8feb9ccf86443b1f5ee1482191cb14a50dddae5b5275b1f9e SHA512 678ab14a8c036e341134e6ae19d422a8888e64ec781983c2eff9d7897298a3b1899b65813351bb566319c931918c034cf0a730aa07c06e48ebac3ddb409a8dee
diff --git a/dev-python/websocket-client/websocket-client-1.5.0.ebuild b/dev-python/websocket-client/websocket-client-1.5.0.ebuild
new file mode 100644
index 000000000000..4e70f6ad65d9
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="WebSocket client for python with hybi13 support"
+HOMEPAGE="
+ https://github.com/websocket-client/websocket-client/
+ https://pypi.org/project/websocket-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}